In this post, I have compiled some useful Commands/Utilities for running Oracle Databases on IBM AIX environments.
Gives useful resource/info about the LPAR/Virtual Server:
$ lparstat -I
The following utilities (topas and nmon) Gives useful resource consumption about the LPAR/Virtual Server (:
$ nmon
-> h
┌─HELP─────────most-keys-toggle-on/off───────────────────────────────────────────────────────────────────┐
│h = Help information q = Quit nmon 0 = reset peak counts │
│+ = double refresh time - = half refresh r = ResourcesCPU/HW/MHz/AIX │
│c = CPU by processor C=upto 1024 CPUs p = LPAR Stats (if LPAR) │
│l = CPU avg longer term k = Kernel Internal # = PhysicalCPU if SPLPAR │
│m = Memory & Paging M = Multiple Page Sizes P = Paging Space │
│d = DiskI/O Graphs D = DiskIO +Service times o = Disks %Busy Map │
│a = Disk Adapter e = ESS vpath stats V = Volume Group stats │
│^ = FC Adapter (fcstat) O = VIOS SEA (entstat) v = Verbose=OK/Warn/Danger │
│n = Network stats N=NFS stats (NN for v4) j = JFS Usage stats │
│A = Async I/O Servers w = see AIX wait procs "="= Net/Disk KB<-->MB │
│b = black&white mode g = User-Defined-Disk-Groups (see cmdline -g) │
│t = Top-Process ---> 1=basic 2=CPU-Use 3=CPU(default) 4=Size 5=Disk-I/O │
│u = Top+cmd arguments U = Top+WLM Classes . = only busy disks & procs │
│W = WLM Section S = WLM SubClasses @=Workload Partition(WPAR) │
│[ = Start ODR ] = Stop ODR i = Top-Thread │
│~ = Switch to topas screen
$ topas
-> h
One-character commands:
@ - Pressing the '@' key repeatedly toggles to wpar and normal mode
a - Show all the variable subsections being monitored. Pressing the
the 'a' key always returns topas to the main initial display.
c - Pressing the 'c' key repeatedly toggles the CPU subsection
between the cumulative report, off, and a list of busiest CPUs.
d - Pressing the 'd' key repeatedly toggles the disk subsection between
total disk, off, and busiest disks list activity for the system.
t - Pressing the 't' key repeatedly toggles the tape subsection between
total tape, off, and busiest tape list activity for the system.
f - Pressing the 'f' key repeatedly toggles the file system subsection
between total file system, off, and busiest file system list activity
for the system.Also Moving the cursor over a WLM class and pressing 'f'
shows the list of top processes in the class on the bottom of the
screen(WLM Display Only).Similarly moving the cursor over a WPAR name and
pressing'f' shows the list of top file system belonging to that wpar
on the bottom of the screen(FS Display with @ option only)
e - Pressing the 'e' key repeatedly toggles between the AME and NFS
subsections. The key has no effect if AME(Active memory expansion)
is not enabled in the machine.
n - Pressing the 'n' key repeatedly toggles the network interfaces subsection
between total network, off, and busiest interfaces list activity.
p - Pressing the 'p' key toggles the hot processes subsection on and off.
P - Toggle to the Full Screen Process Display
q - Quit the program r - Refresh the screenGives useful resource consumption about the System Memory info (Including Large Page Consumption/Information):
$ svmon
Gives Disk Usage Information on/attached-to the LPAR:
$ df -g
Gives useful resource/info about the LPAR/Virtual Server:
$ lparstat -I
The following utilities (topas and nmon) Gives useful resource consumption about the LPAR/Virtual Server (:
$ nmon
-> h
┌─HELP─────────most-keys-toggle-on/off───────────────────────────────────────────────────────────────────┐
│h = Help information q = Quit nmon 0 = reset peak counts │
│+ = double refresh time - = half refresh r = ResourcesCPU/HW/MHz/AIX │
│c = CPU by processor C=upto 1024 CPUs p = LPAR Stats (if LPAR) │
│l = CPU avg longer term k = Kernel Internal # = PhysicalCPU if SPLPAR │
│m = Memory & Paging M = Multiple Page Sizes P = Paging Space │
│d = DiskI/O Graphs D = DiskIO +Service times o = Disks %Busy Map │
│a = Disk Adapter e = ESS vpath stats V = Volume Group stats │
│^ = FC Adapter (fcstat) O = VIOS SEA (entstat) v = Verbose=OK/Warn/Danger │
│n = Network stats N=NFS stats (NN for v4) j = JFS Usage stats │
│A = Async I/O Servers w = see AIX wait procs "="= Net/Disk KB<-->MB │
│b = black&white mode g = User-Defined-Disk-Groups (see cmdline -g) │
│t = Top-Process ---> 1=basic 2=CPU-Use 3=CPU(default) 4=Size 5=Disk-I/O │
│u = Top+cmd arguments U = Top+WLM Classes . = only busy disks & procs │
│W = WLM Section S = WLM SubClasses @=Workload Partition(WPAR) │
│[ = Start ODR ] = Stop ODR i = Top-Thread │
│~ = Switch to topas screen
$ topas
-> h
One-character commands:
@ - Pressing the '@' key repeatedly toggles to wpar and normal mode
a - Show all the variable subsections being monitored. Pressing the
the 'a' key always returns topas to the main initial display.
c - Pressing the 'c' key repeatedly toggles the CPU subsection
between the cumulative report, off, and a list of busiest CPUs.
d - Pressing the 'd' key repeatedly toggles the disk subsection between
total disk, off, and busiest disks list activity for the system.
t - Pressing the 't' key repeatedly toggles the tape subsection between
total tape, off, and busiest tape list activity for the system.
f - Pressing the 'f' key repeatedly toggles the file system subsection
between total file system, off, and busiest file system list activity
for the system.Also Moving the cursor over a WLM class and pressing 'f'
shows the list of top processes in the class on the bottom of the
screen(WLM Display Only).Similarly moving the cursor over a WPAR name and
pressing'f' shows the list of top file system belonging to that wpar
on the bottom of the screen(FS Display with @ option only)
e - Pressing the 'e' key repeatedly toggles between the AME and NFS
subsections. The key has no effect if AME(Active memory expansion)
is not enabled in the machine.
n - Pressing the 'n' key repeatedly toggles the network interfaces subsection
between total network, off, and busiest interfaces list activity.
p - Pressing the 'p' key toggles the hot processes subsection on and off.
P - Toggle to the Full Screen Process Display
q - Quit the program r - Refresh the screenGives useful resource consumption about the System Memory info (Including Large Page Consumption/Information):
$ svmon
Gives Disk Usage Information on/attached-to the LPAR:
$ df -g